Back to overview
Degraded
Issues with accessing panels
Nov 18 at 12:00pm GMT
Affected services
Main website
VPS panel
Minecraft panel
Resolved
Nov 18 at 05:00pm GMT
Cloudflare fixed the problem.
Affected services
Updated
Nov 18 at 02:37pm GMT
All our panels are available, but Cloudflare hasn't announced a full fix yet, so there may still be some issues.
Affected services
Created
Nov 18 at 12:00pm GMT
Some of our services are available through Cloudflare tunnel.
Unfortunately, Cloudflare has been experiencing technical difficulties since 11:45am today.
We believe that the problem will be solved as soon as possible!
We apologize for the inconvenience
Affected services